121.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

单臂路由是指在路由器的一个接口上通过配置子接口的方式,实现原来相互隔离的不同VLAN虚拟局域网之间的互联互通。Cisco网络认证体系中,单臂路由是一个重要知识点。通过单臂路由能够深入的了解VLAN虚拟局域网的划分、封装、通信原理。

项目拓扑

项目拓扑如图:

121-1.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

需求分析

PC3可以Ping通PC0/Server0。

公司因为业务需求,需要部门之间可以通信。因为处于不同网段,所以需要路由实现寻址。又因多个部门使用同一交换划VLAN,所以需要借助单臂路由技术。

项目方案

通过单臂路由实现。

通过在路由器上开启子接口,并将子接口划分在各部门的VLAN内,通过Trunk封装实现交换机与路由间的VLAN同步,从而实现跨VLAN通信。

方案步骤

  • Router0路由器:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1.2
Router(config-subif)#encapsulation dot1Q 2
Router(config-subif)#ip address 192.168.2.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastEthernet 0/1.3
Router(config-subif)#encapsulation dot1Q 3
Router(config-subif)#ip address 192.168.3.1 255.255.255.0
  • Switch0交换机:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
Switch>enable
Switch#configure terminal
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#vlan 2
Switch(config-vlan)#exit
Switch(config)#vlan 3
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/3
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#interface range fastEthernet 0/4-5
Switch(config-if-range)#switchport access vlan 3

方案测试

测试结果如图:

121-2.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

项目扩展

  1. 单臂路由使用思科路由虚拟端口技术,实现单一端口不同网段;

  2. 单臂路由的作用是解决思科路由设备端口不够用的问题;

  3. 设置单臂路由需要配合交换机VLAN技术;

  4. 交换与路由相连的端口需要开Trunk。


 评论