抱歉,您的浏览器无法访问本站

本页面需要浏览器支持(启用)JavaScript


了解详情 >

之前我们学习了思科的动态路由,这种路由协议,一般应用于中小型架构。后来,我们又了解 OSPF 路由协议,这种协议一般用于大型网络。那么如何让这两种网络通信!

实验前提

相比 OSPF 的区域宣告,动态路由使用全网宣告,这两个矛盾体如何实现通信?今天我们就来学习下路由重定向。

首先需要对照《思科动态路由》以及《简单聊OSPF》教程配置下图,Router0 和 Router1 使用的动态路由,剩下路由使用的 OSPF 协议,其中 Router2 和 Router3 的 Fa0/0 都是 area 0,Router3 的 Fa0/1 口、Router4 和 Router5 都是 area 1。

实验拓扑

实验拓扑如图:

方案步骤

Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#interface FastEthernet0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config-if)#exit
Router(config)#interface FastEthernet0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 192.168.2.0
Router(config-router)#exit
Router(config)#router ospf 1111
Router(config-router)#network 192.168.3.0 0.0.0.255 area 0
Router(config-router)#exit
Router(config)#route rip
Router(config-router)#redistribute ospf 1111 metric 2
Router(config-router)#exit
Router(config)#router ospf 1111
Router(config-router)#redistribute rip subnets

注意:以上命令在 Router1 路由器上设置,我们可以发现,在做重定向时,需要在连接的路由器上,同时配置动态路由和 OSPF。

方案测试

最后我们测试一下,首先是 Ping:

然后查看下路由表:

评论