47.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

之前讲了如何配置静态路由。现在我们又遇到了一个问题,如图我们增加一个路由。如果我们还像之前那样通过静态路由配置,想想看是不是麻烦很多。所以今天我们学习一下动态路由。

项目拓扑

项目拓扑如图:

47-1.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

需求分析

PC0可以Ping通PC1。

Router0只知道两个网段,分别是192.168.1.0/192.168.2.0。Router1只知道两个网段,分别是192.168.2.0/192.168.3.0。Router2只知道两个网段,分别是192.168.3.0/192.168.4.0。所以如果想要PC0可以Ping通PC1,必须告诉0路由器192.168.3.0/192.168.4.0的走向,并且因为需要回包,所以2路由器需要知道192.168.1.0/192.168.2.0的走向。同时需要1路由器知道192.168.1.0/192.168.4.0的走向。

项目方案

通过动态路由实现。

项目可以通过静态路由实现,不过实现起来工程量比较大,因为需要规划所有网段走向。这里同样可用动态路由实现。动态路由会把路由器已知的网段宣告出去,其它路由通过学习即可自动判断走向。

方案步骤

  • Router0路由器:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
  • Router1路由器:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.3.0
  • Router2路由器:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.3.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.4.0

方案测试

测试结果如图:

47-2.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

项目扩展

  1. 动态路由会持续产生数据包占用网络;

  2. 动态路由如不宣告则不学习,故无法与静态路由结合使用;

  3. 动态路由有跳数的限制,允许15跳,故路由设备不可以超过16台。


 评论