48.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

我们发现思科动态路由协议也有其局限性,一个网络中只能存在16台路由器。那如何破解这个局限性?我们今天学习一种新的路由协议,叫EIGRP,它的跳数超过16跳,不过缺点是它属于思科私有协议,其它厂家网络设备并不支持。

项目拓扑

项目拓扑如图:

48-1.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

需求分析

PC0可以Ping通PC1。

Router0只知道两个网段,分别是192.168.1.0/192.168.2.0。Router1只知道两个网段,分别是192.168.2.0/192.168.3.0。Router2只知道两个网段,分别是192.168.3.0/192.168.4.0。所以如果想要PC0可以Ping通PC1,必须告诉0路由器192.168.3.0/192.168.4.0的走向,并且因为需要回包,所以2路由器需要知道192.168.1.0/192.168.2.0的走向。同时需要1路由器知道192.168.1.0/192.168.4.0的走向。

项目方案

通过动态路由实现。

我们只是通过少量设备演示,如果大家有时间和精力,可以大量添加路由设备。

方案步骤

  • Router0路由器:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router eigrp 1
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
  • Router1路由器:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router eigrp 1
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.3.0
  • Router2路由器:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.3.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router eigrp 1
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.4.0

方案测试

测试结果如图:

48-2.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

技术特点

  1. 快速收敛;

  2. 部分更新;

  3. 支持多种网络层的协议;

  4. 使用多播、单播;

  5. 支持变长子网掩码;

  6. 无缝连接数据链路层协议和拓扑结构;

  7. 配置简单。


 评论