49.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

在生产环境中,我们需要使用多个网段,如果在连接这些网段的路由中配置DHCP服务,会增加我们的维护成本,这时我们可以使用DHCP的中继功能,来实现跨网段IP分配。

项目拓扑

项目拓扑如图:

49-1.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

需求分析

PC0可以获取IP。

配置路由设备可以使其具备DHCP的功能,但图中的DHCP服务端与客户端之间存在另外一台路由设备,而该设备没有配置DHCP的功能。

项目方案

通过DHCP中继路由器实现。

客户端在向最近的路由器请求IP,而最近的路由器并非DHCP的服务端,但是它知道要找谁要IP,根据指向地址,中继将获取到的地址发给客户端。

方案步骤

  • Router0路由器:
1
2
3
4
5
6
7
8
9
10
11
12
13
Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ip dhcp pool cjk
Router(dhcp-config)#network 192.168.2.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.2.1
Router(dhcp-config)#dns-server 8.8.8.8
Router(dhcp-config)#exit
Router(config)#ip route 192.168.2.0 255.255.255.0 fastEthernet 0/0
  • Router1路由器:
1
2
3
4
5
6
7
8
9
10
11
Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#ip helper-address 192.168.1.1
Router(config-if)#no shutdown

方案测试

测试结果如图:

49-2.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

注意事项

  1. 在配置IP地址池时,所设置的网关是否是目标网段的网关;

  2. DHCP中继端需要直接指向DHCP服务端,不可指向其它中继。


 评论