50.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

当在专用网内部的一些主机本来已经分配到了本地的IP地址,但现在又想和因特网上的主机通信时,可使用NAT方法。这种方法需要在专用网连接到因特网的路由器上安装NAT软件。装有NAT软件的路由器叫做NAT路由,它至少有一个有效的外部全球IP地址。这样,所有使用本地地址的主机在和外界通信时,都要在NAT路由器上将其本地地址转换成全球IP地址,才能和因特网连接。

项目拓扑

项目拓扑如图:

50-1.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

需求分析

PC0可以Ping通PC1。

私网地址只能在内网中使用,外网不允许出现私网IP。

项目方案

要将内网的源地址转换为外网的地址,数据包才可以在网络中流通。

这里可以使用网络地址转换实现。NAT会将内网的地址转换为外网的地址,数据包返回后,目标地址指向边际路由,路由会将外网地址转换成内网的地址,再发现内网的目标终端。

方案步骤

  • Router0路由器:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 0/1
Router(config)#ip nat inside source static 192.168.1.2 1.1.1.2
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#ip nat inside
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 1.1.1.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#ip nat outside
  • Router1路由器:
1
2
3
4
5
6
7
8
9
10
Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 2.2.2.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 1.1.1.1 255.0.0.0
Router(config-if)#no shutdown

方案测试

测试结果如图:

50-2.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

项目扩展

  1. 网络地址转换有很多种,如果按照地址分类,可分为源地址转换、目标地址转换;

  2. 如果按照功能分类,可分为一对一的NAT,多对多DNAT动态网络地址转换,一对多PAT,也称为PNAT,是基于端口的网络地址转换。


 评论