56.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

通过网络地址转换,我们可以实现终端访问外网,但是我们发现,同一时间只有一个终端可以上网,如何实现多台终端同时上网?我们学习一下基于端口的NAT。

项目拓扑

项目拓扑如图:

56-1.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

需求分析

左侧两个PC可同时连通右侧的PC。

NAT只能转换一个内网IP为一个外网IP,所以无法实现多台内网设备同时连通外网。

项目方案

网络中的通信除了依赖IP地址外,还需要使用端口来进行通信,所以借助端口,我们可以实现多对一的转换形式。

通过基于端口的NAT,即PNAT,也称为PAT,可以将多个内网IP,同时映射到一个网络接口上,通过一个外网地址,不同端口实现地址转换。

方案步骤

  • R1路由器:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 1/0
Router(config)#access-list 1 permit any
Router(config)#ip nat inside source list 1 interface fastEthernet 1/0 overload
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#ip nat inside
Router(config-if)#exit
Router(config)#interface fastEthernet 1/0
Router(config-if)#ip address 1.1.1.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#ip nat outside
  • R2路由器:
1
2
3
4
5
6
7
8
9
10
Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 2.2.2.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 1/0
Router(config-if)#ip address 1.1.1.1 255.0.0.0
Router(config-if)#no shutdown

方案测试

56-2.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

注意:上图为第一台PC进行连通性测试。

56-3.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

注意:上图为第二台PC进行连通性测试。

56-4.jpg?x-oss-process=image/auto-orient,1/quality,q_90/watermark,image_bG9nby5wbmc_eC1vc3MtcHJvY2Vzcz1pbWFnZS9yZXNpemUsUF8yMA,g_center,t_50,x_10,y_10

注意:在特权模式下,使用show ip nat translations查询nat转换列表。

项目扩展

  1. 绝大多数路由设备,都会使用PAT来进行网络地址转换;

  2. PAT需配合ACL来实现内网地址列表。


 评论